MOVING TO NEW FORUM link https://telestreamforum.forumbee.com This forum will become READ ONLY on Wednesday May 25, 2016

Telestream Community Forum
Decrease font size
Increase font size
Topic Title: 4.5.2 Wont Update Audio Driver
Topic Summary: Updated screenflow through appstore and audio wont work
Created On: 7/11/2014 9:31 AM
Status Read Only
Linear : Threading : Single : Branch
Topic Tools Search Topic
Topic Tools Topic Tools
View topic in raw text format. Print this topic.
 7/11/2014 9:31 AM
User is offline View Users Profile Print this message

Author Icon
Seniac

Posts: 2
Joined: 7/11/2014

Hi i was about to record when i noticed there was an update for screenflow in the appstore so i updated all was fine then as i go to record in 4.5.2 i check computer audio box and tells me i need to install the driver so i do that then go to record once more and still tells me i need to install the audio driver BUT I HAVE LIKE 10 TIMES!!

Everything works fine i just cannot record computer audio as it keeps asking for the driver i already had/keep on installing

any help? im a bit annoyed due tyo the fact i have limited to to record videos and i have this problem?

i am on mac mavericks 10.9.4
 7/11/2014 9:36 PM
User is offline View Users Profile Print this message

Author Icon
CraigS

Posts: 54277
Joined: 4/4/2007

Make sure you're in an Admin account.
Repair Disc Permissions.
Reboot.
Install ScreenFlow again.

-------------------------
CraigS
Telestream Desktop Forum Moderator
 7/13/2014 3:03 AM
User is offline View Users Profile Print this message

Author Icon
nicklom

Posts: 3
Joined: 7/13/2014

I'm having a similar issue. Whenever I try to record with Computer Audio on, a box interrupts and says, "Recording Error Due to an internal error, the recording has unexpectedly terminated. Please try making your recording again, and if problems persist, contact us for technical support." I went to the troubleshooting page at http://www.telestream.net/tele...rt/screen-flow/faq.htm, and it still doesn't work. I didn't even have the two files that it said to delete.
I'm also on an iMac with Mavericks 10.9.4 and I bought ScreenFlow through the App Store.
 7/14/2014 5:35 PM
User is offline View Users Profile Print this message

Author Icon
CraigS

Posts: 54277
Joined: 4/4/2007

It's not clear whether you followed the instructions I posted though.
Please confirm you've followed the steps I listed.

-------------------------
CraigS
Telestream Desktop Forum Moderator
 9/4/2014 1:53 PM
User is offline View Users Profile Print this message

Author Icon
CraigS

Posts: 54277
Joined: 4/4/2007

Did you buy ScreenFlow from App Store or website?
"Don't Work" Please explain. Are you getting any error messages?
Are you using an Admin account?
Sorry but I can't make any assumption. I'd need complete details.

Have you followed these instructions?
http://telestream.force.com/kb...eenFlow&fs=Search&pn=1

-------------------------
CraigS
Telestream Desktop Forum Moderator
 9/4/2014 5:02 PM
User is offline View Users Profile Print this message

Author Icon
oswaldolinhares

Posts: 2
Joined: 9/4/2014

I'm having a similar issue. I followed the instructions You posted though. HELP-ME
 9/4/2014 5:21 PM
User is offline View Users Profile Print this message

Author Icon
oswaldolinhares

Posts: 2
Joined: 9/4/2014

Step by Step:
Deleted ScreenFlow
Repair Disc Permissions
Reboot
Install ScreenFlow again
Install ScreenFlow Audio Driver 4.5.2
Reboot
Don't Work.

Marvericks 10.9.4
 9/12/2014 12:36 AM
User is offline View Users Profile Print this message

Author Icon
nickdubz

Posts: 1
Joined: 9/12/2014

Has anyone been able to solve this?

Just a week or two ago I did a recording with Screenflow, recording audio from my headset and recording audio from my computer, no issues, everything went great. But now just 2 days ago when I went to try and record again, the "Record Computer Audio" checkbox was gone and it wanted me to install the telestream driver, so I did and now whenever I try to go and record, I get the "Recording Error, Due to an internal error..." etc it was mentioned in this thread already.

I can record my headset with no issues, but if I check the computer audio box I get that error message.

I've tried all of the various fixes, nothing seems to work
 9/12/2014 9:15 AM
User is offline View Users Profile Print this message

Author Icon
CraigS

Posts: 54277
Joined: 4/4/2007

The audio driver in ScreenFlow 4.5.2 has problems with OS 10.7.x but should work fine with 10.8.x and 10.9.x
I'd need to know SF and OS versions.
I'd also recommend uninstalling ScreenFlow, repairing disk permissions and trying to install again.
It's possible some other program which uses an audio driver is blocking ScreenFlow's audio driver installing.
You may want to remove software like Soundflower or other programs that provide audio drivers.

-------------------------
CraigS
Telestream Desktop Forum Moderator
 9/25/2014 3:51 PM
User is offline View Users Profile Print this message

Author Icon
wmatthews

Posts: 2
Joined: 9/25/2014

The same thing is happening to me. The installer reports that it completes successfully but it doesn't actually install the file, I checked the System folder for the driver file and it's not there. I'm running OS 10.9.4 and am using the latest version of ScreenFlow and trying the TelestreamAudio-4.5.2.pkg installer.
 9/25/2014 4:15 PM
User is offline View Users Profile Print this message

Author Icon
CraigS

Posts: 54277
Joined: 4/4/2007

Can you confirm it's ScreenFlow 4.5.2. I must have version numbers because people often say "latest" and might not be accurate.
Are you doing this from an Admin account?
Have you repaired disk permissions?
Have you tried going into ScreenFlow Preferences Advanced Computer Audio and tried installing the driver there?
Have you followed the instructions I linked to on 9/4 ?

Do you have any non Apple software that might have installed Audio Components?
SoundFlower or any other audio specific software are software that screen captures audio?

-------------------------
CraigS
Telestream Desktop Forum Moderator
 9/25/2014 4:52 PM
User is offline View Users Profile Print this message

Author Icon
wmatthews

Posts: 2
Joined: 9/25/2014

Fair point, despite having just reinstalled from the App Store, it turns out it was version 3.0.8--didn't realize there were multiple versions on the store. I re-downloaded the 4.5.2 installer directly from the site and it seems to be working now. Just my two cents, but might be worth adjusting the audio driver download landing page for those still on the older 3.0.8 version so that it doesn't get confusing? At any rate, thanks for prompting the heads-up, I'm back up and running again!
 9/26/2014 8:00 AM
User is offline View Users Profile Print this message

Author Icon
CraigS

Posts: 54277
Joined: 4/4/2007

Good to hear.

If you'd like, do make the request regarding the audio driver landing page.
http://www.telestream.net/tele...ow/contact-support.htm

-------------------------
CraigS
Telestream Desktop Forum Moderator
 11/23/2014 1:00 PM
User is offline View Users Profile Print this message

Author Icon
robvun

Posts: 2
Joined: 11/23/2014

No luck. Screenflow 4.5.4 on OS X 10.7.5 (latest possible OS on my Mac Pro).

Yes, I use other audio software, such as Pro Tools, Audacity and more. It is unthinkable that I uninstall all that for being able to use Screenflow's Record Computer Audio option. So what do I do wrong? And how can I do it right?
 11/24/2014 6:18 PM
User is offline View Users Profile Print this message

Author Icon
CraigS

Posts: 54277
Joined: 4/4/2007

Since it's your first post, I don't have any history and would prefer not make any assumptions.
At what point did you develop issues with installing the audio driver? What previously worked?

-------------------------
CraigS
Telestream Desktop Forum Moderator
 11/25/2014 6:26 AM
User is offline View Users Profile Print this message

Author Icon
robvun

Posts: 2
Joined: 11/23/2014

@ScraigS - Cannot tell you when the problem started. Maybe I didn't use the option Record Computer Audio, maybe I checked Record Audio from: chosing Soundflower (2ch). I can still do that. But I think the options offered by the application should work and this one doesn't. I install the driver, but when I check Record Computer Audio I'm invited to install the Audio Driver over and over again.
 11/25/2014 1:17 PM
User is offline View Users Profile Print this message

Author Icon
CraigS

Posts: 54277
Joined: 4/4/2007

Please uninstall SoundFlower (and SoundFlower Bed) and all its components. Reboot and then uninstall ScreenFlow. Reboot, try installing ScreenFlow again. Start ScreenFlow and go into Preferences Advanced and if it says Install Driver, select that.

When uninstalling SoundFlower please post all the components you've uninstalled to make sure I can see if you've might have missed anything.

-------------------------
CraigS
Telestream Desktop Forum Moderator
 1/6/2015 5:04 PM
User is offline View Users Profile Print this message

Author Icon
kacole2

Posts: 1
Joined: 1/6/2015

i was able to fix this by manually installing the TelestreamAudio.kext driver.

Read here for a complete how-to:
http://kendrickcoleman.com/ind...ng-computer-audio.html
 1/6/2015 7:40 PM
User is offline View Users Profile Print this message

Author Icon
CraigS

Posts: 54277
Joined: 4/4/2007

But that doesn't explain what blocked the initial installation. Problem may not be solved if that is not addressed.

-------------------------
CraigS
Telestream Desktop Forum Moderator
 4/27/2016 12:23 PM
User is offline View Users Profile Print this message

Author Icon
gerardodiego

Posts: 3
Joined: 4/27/2016

Hi! I have the same problem. I'm running:

OSX El Capitan, 10.11.4
ScreenFlow 4.5.2 (22160)

I was following kacole2's instructions, but the contents of the package that Telestream is offering for downloading is containing some very small files. Maybe this is correct, but there's no kext file in there. Also, after running the installation several times, there is nothing at /System/Library/Extensions.

Also as many others, this used to work. And I don't have any other app that could be using audio. So I have nothing to uninstall. I'll try reinstalling ScreenFlow.

 4/27/2016 12:27 PM
User is offline View Users Profile Print this message

Author Icon
gerardodiego

Posts: 3
Joined: 4/27/2016

CraigS, did you give up on this?
 4/27/2016 3:28 PM
User is offline View Users Profile Print this message

Author Icon
CraigS

Posts: 54277
Joined: 4/4/2007

Screenflow 4.5.x is not compatible with El Capitan. We don't support the combination.

-------------------------
CraigS
Telestream Desktop Forum Moderator

FuseTalk Basic Edition v4.0 - © 1999-2017 FuseTalk Inc. All rights reserved.

MOVING TO NEW FORUM link https://telestreamforum.forumbee.com This forum will become READ ONLY on Wednesday May 25, 2016